MediaWiki Core Minimum PHP Requirements Increased to 5.5.9 or Newer

From mwstake
Revision as of 14:45, 11 February 2016 by Chris Koerner (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

by on

Tag.png Tags: 1.27, Breaking, Core, Future, PHP
Person.png People: Kunal Mehta

Legoktm announced that MediaWiki core now requires PHP 5.5.9 or newer moving forward. This implementation came after a long discussion, in places like Phabricator, request for comments on Mediawiki. org, iRC meetings - all with WMF staff and volunteer developers.

The change is a positive one. The previous minimum version for MediaWiki was 5.3, which was released in July 2010. That version is no longer seeing updates, and was quite old in program-language-time. Newer versions of PHP have brought bug and security fixes, performance improvements, and modernizations to the language. The most current version of PHP is 7.0.3. This sets up the next version of Mediawiki (1.27) a a LTS (long-term support) release until May 2019. At which point PHP 5.5 will be ancient. :)

Since this change will also have an impact to extensions, Legoktm also released a list of MediaWiki extensions that have unit tests and their status - including those that are failing!:

For those of you using MediaWiki on older releases of PHP, please consider updating. It's part of being a good citizen of the Internet and can prevent so many headaches in security and updates down the road.