MediaWiki Core Minimum PHP Requirements Increased to 5.5.9 or Newer

From mwstake
Revision as of 14:40, 11 February 2016 by Chris Koerner (talk | contribs)
Jump to: navigation, search

by on 11 February 2016 14:40 (EST)

Tag.png Tags: 1.27, Breaking, Core, Future, PHP
Person.png People: Kunal Mehta

Legoktm announced that MediaWiki core now requires PHP 5.5.9 or newer moving forward. This implementation came after a long discussion, in Phabricator with WMF staff and volunteer developers.

The change is a positive one. The previous minimum version for MediaWiki was 5.3, which was released in July 2010. That version is no longer seeing updates, and was quite old in program-language-time. Newer versions of PHP have brought bug and security fixes, performance improvements, and modernizations to the language. The most current version of PHP is 7.0.3. This sets up the next version of Mediawiki (1.27) a a LTS (long-term support) release until May 2019. At which point PHP 5.5 will be ancient. :)

Since this change will also have an impact to extension, Legoktm also released a list of externs that have unit tests and their status - including those that are failing!: https://www.mediawiki.org/wiki/User:Legoktm/PHP_5.5/Extensions