Difference between revisions of "Blog Post:39"

From mwstake
Jump to: navigation, search
(Created page with "{{Blog Post |title=MediaWiki Core Minimum PHP Requirements Increased to 5.5.9 or Newer |tags=Core, PHP, 1.27, Breaking, Future, |people=Kunal Mehta, |author=Chris Koerner }} [...")
 
Line 7: Line 7:
 
[http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/85669 Legoktm announced] that MediaWiki core now requires PHP 5.5.9 or newer moving forward. This implementation came after a long discussion, [https://phabricator.wikimedia.org/T118932 in Phabricator] with WMF staff and volunteer developers.
 
[http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/85669 Legoktm announced] that MediaWiki core now requires PHP 5.5.9 or newer moving forward. This implementation came after a long discussion, [https://phabricator.wikimedia.org/T118932 in Phabricator] with WMF staff and volunteer developers.
  
The change is a positive one. The previous minimum version for MediaWiki was 5.3, which was released in July 2010. That version is no longer seeing updates, and was quite old in program-language-time. Newer versions of PHP have brought bug and security fixes, performance improvements, and modernizations to the language. The most current version of PHP is 7.0.3. This sets up the next version of Mediawiki (1.27) a a LTS (long-term support) release until May 2019. At which point PHP 5.5 will be ancient. :)
+
The change is a positive one. The previous minimum version for MediaWiki was 5.3, which was released in July 2010. That version is no longer seeing updates, and was quite old in program-language-time. Newer versions of PHP have brought bug and security fixes, performance improvements, and modernizations to the language. The most current version of PHP is 7.0.3. This sets up the next version of Mediawiki (1.27) a a LTS (long-term support) [https://www.mediawiki.org/wiki/Version_lifecycle release until May 2019]. At which point PHP 5.5 will be ancient. :)
  
 
Since this change will also have an impact to extension, Legoktm also released a list of externs that have unit tests and their status - including those that are failing!: https://www.mediawiki.org/wiki/User:Legoktm/PHP_5.5/Extensions
 
Since this change will also have an impact to extension, Legoktm also released a list of externs that have unit tests and their status - including those that are failing!: https://www.mediawiki.org/wiki/User:Legoktm/PHP_5.5/Extensions

Revision as of 15:40, 11 February 2016

by on 11 February 2016 14:40 (EST)

Tag.png Tags: 1.27, Breaking, Core, Future, PHP
Person.png People: Kunal Mehta

Legoktm announced that MediaWiki core now requires PHP 5.5.9 or newer moving forward. This implementation came after a long discussion, in Phabricator with WMF staff and volunteer developers.

The change is a positive one. The previous minimum version for MediaWiki was 5.3, which was released in July 2010. That version is no longer seeing updates, and was quite old in program-language-time. Newer versions of PHP have brought bug and security fixes, performance improvements, and modernizations to the language. The most current version of PHP is 7.0.3. This sets up the next version of Mediawiki (1.27) a a LTS (long-term support) release until May 2019. At which point PHP 5.5 will be ancient. :)

Since this change will also have an impact to extension, Legoktm also released a list of externs that have unit tests and their status - including those that are failing!: https://www.mediawiki.org/wiki/User:Legoktm/PHP_5.5/Extensions